Installation d'un Xiaomi Mini-Router

De Vulcainreo, lun. 12 octobre 2015, dans la catégorie Bidouille

Bidouille

Il y a quelques semaine j'ai craqué sur un Xiaomi Mini-router. Pour 25€, vous recevez un véritable router. Enfin, un router qui ne sait que parler chinois (heureusement qu'il y a Google Traduction :))

Achat

Le router se trouve à bon prix ici

Flash

Une procédure de flash est disponible ici : http://en.miui.com/thread-64391-1-1.html Dans cette procédure, après avoir donné votre adresse IP en chine et associé votre router avec votre compte Xiaomi, vous pourrez télécharger l'ensemble des Firmware.

Fichier

Par soucis d'efficacité, voici tous les fichiers nécessaires : Github

/!\ Ceux-ci date du 12/10/2015 et seront surement plus à jour au moment de votre flash.

Procédure

Configuration en borne AP (Dumb-AP)

D'après les forums, cette configuration peut être réalisée par l'interface. Néanmoins, après une bonne soirée à configurer -> perdre l'accès -> reset -> reconfiguré, rien ne vaut une véritable configuration via Telnet.

xiaomi-miniRouter/>Telnet 192.168.1.1
xiaomi-miniRouter/>Vim /etc/network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd64:e1da:6db7::/48′

config interface ‘lan’
option ifname ‘eth0.1 eth0.2′
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.2’
option netmask ‘255.255.255.0’
#option ip6assign ’60’
option gateway ‘192.168.1.1’
option dns ‘192.168.1.1’

#config interface ‘wan’
#option ifname ‘eth0.2′
#option proto ‘dhcp’

config interface ‘wan6′
option ifname ‘@wan’
option proto ‘dhcpv6′

config switch
option name ‘switch0′
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0′
option vlan ‘1’
option ports ‘0t 2 3 4 5′

config switch_vlan
option device ‘switch0′
option vlan ‘2’
option ports ‘0t 1′